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Lesson Plan for:  Excel – Data Analysis (Sample) 
 

  Delivery Format: Online/In-Person 

Program Objectives: 

Basic Functions 

Data Cleaning  

Sort and Filter  

Advanced Functions 

Pivot Tables 

 

Introduction: 

Click here to enter text. 

Closing: 

Click here to enter text. 

Program Time: 

Preparation: 2 Hours   

Delivery: Online  

 

Online requirements: Zoom meeting link, Computer (either laptop or desktop computer) or phone if 

participant wants to dial in, link to supplementary materials for participants, link to online evaluation.  

Resources: Click here to enter text.  

 

Delivery Format: Online (Expand if teaching online) 
• Collapse this section if you are teaching this class in-person. 

Online Setup (staff): 30 minutes Prior to Program Start 
 

• Online setup & troubleshooting time  

Program Portal Catalog ID #: Click here to enter text. 
Target Audience(s): ☒Older Adults Ages 65+ ☒Adults Ages 19-64 ☒Teens Ages 12-18 

 ☐Preteens Ages 10-11 ☐School Age 5-11 ☐Preschool Ages 3-5 

 ☐Toddlers Age 19-36 

Months 

☐Babies/Toddlers Ages 0-

18 Months 

☐Families 

 
Focus Area: 

 
Continual Learning for Adults 
 

https://edu.gcfglobal.org/en/excel/


   
 

 

o Lead facilitator should join the Zoom Room used to schedule the program.  

▪ Primary: DigiLit Zoom Account 

• Username: cmldigitalinclusion 

• Password: Digital4ever  

▪ Secondary (if schedule conflict) Adult Services Zoom Account 

• Username: adultservices.cml@gmail.com 

• Password: Adult2020 

▪ Link (for co-facilitator/participants): [Insert Link] 

  

▪ Give Co-host privileges to Library staff 

• Zoom Pro Tip: Can request or give remote control of your screen during 

program if co-facilitating. Can be enabled through entire program. 

▪ Paste into Zoom chat box:  

• Welcome to [program topic]! We’ll get started in just a few minutes. 

• Link to Class Handout on Digital Branch page (if available) 

• Link to Activity Sheet on Digital Branch page (if available) 

o [Optional] Log in to staff OneDrive account https://www.office.com/ while teaching to 

demonstrate the Microsoft 365 free version (Microsoft Edge browser recommended)  

▪ Username: cmlvirtualcomputerclasses@outlook.com 

▪ Password: CM!techt3am 

▪ Create or duplicate a OneDrive workbook containing activities from the Activity 

Sheet if applicable 

 

Online Introductions [ 6 minutes]   
*PowerPoint Slides 

• Launch PowerPoint Intro [insert link to ppt] & share screen 

• Staff introductions (point out who is monitoring chat for questions, etc.) 

• Participant Introductions: 

o Ice-breaker activity (Example: Your name; Why do you want to learn Excel? What 

version of Excel are you using today?) 

• Recording disclaimer (if applicable)  

• Hit Record Button 
• Review of navigating Zoom and procedures: 

o Attendee Controls in a Meeting  

▪ Mute: All participants will be muted at the start of the call. 

▪ Raise hand: If participant wants to speak, use the raise hand feature and the 

moderator will ask the person to unmute their mic and speak (microphone 

option in center of screen) 

▪ Settings: Add in your name 

▪ Encourage to turn on video, but not required 

▪ Chat: open chat feature 

• Quick Tips for Online Programs (Windows) 

mailto:adultservices.cml@gmail.com
https://support.zoom.us/hc/en-us/articles/201362673-Requesting-or-giving-remote-control#heading=h.65ma9ec1h8lm
https://www.office.com/
mailto:cmlvirtualcomputerclasses@outlook.com
https://support.zoom.us/hc/en-us/articles/200941109-Attendee-controls-in-a-meeting
https://support.microsoft.com/en-us/help/12445/windows-keyboard-shortcuts


   
 

 

o Alt + Tab (Switch between open apps. Hold down Alt key and press Tab to select) 

o Ctrl + Alt + Tab (Use the arrow keys to switch between all open apps, OR click) 
o Ctrl + Tab (Switch between tabs in browser. Hold down Ctrl key and press Tab to select) 

o Press and hold Windows Logo key, press the left or right arrow key (will arrange open 

windows side by side) 

Delivery Format: In-Person (Expand if teaching in-person) 
• Collapse this section if you are teaching online. 

In-Person Introductions [6 minutes] 
*PowerPoint Slides 

• Launch PowerPoint Intro [insert link to ppt]  

• Staff introductions  

• Participant Introductions: 

o Ice-breaker activity (Example: Your name; Why do you want to learn Excel? What 

version of Excel are you using today?) 

Topic Introduction  [-minutes] 
*PowerPoint Slides 

• Objectives – from PowerPoint slide 

• Project – Create a personal webpage 

Suggested Activity: Go to  

*Continue with PowerPoint or turn off slides and switch to demonstration or share screen 

What is Data Analysis?   [-minutes] 
 

Data analysis is the process of gathering, cleaning, and modeling data to reveal meaningful 

insights. This data is then crafted into reports that support the strategic decision-making 

process. 

Suggested Activity: Click or tap here to enter text. 

Dataset   [-minutes] 
Open the dataset sent by email. The data set is a list of fighters.  

So far, we’ve talked about “rows” and “columns” since these are common features of “tables”. Because 

Excel is a visual interface, these terms are commonly used. But there are some terms that are more 

often used in Analytics. 

A column is better known as a variable. A row of data is known as an observation, since each row 

represents something that was observed. For the current dataset, each observation represents a fighter 

who is trying to save the world. This is known as the dataset’s level of detail (variable with unique 

values: Character Name) and is very important to identify before beginning an analysis.  



   
 

 

 

Suggested Activity: Click or tap here to enter text.  

Basic Functions   [-minutes] 
Change tabs to the Basic Functions tab. Let’s go over the following functions.  

Sum - Adds numbers in a range.  

 =SUM 

Average - Calculates the average (arithmetic mean) 

 =AVERAGE 

Min - Finds the lowest number in a range 

 =MIN 

Max - Finds the highest number in a range 

 =MAX 

Count - Counts cells with numbers in a range 

=COUNT 

Counta - Counts all cells in a range that has values, both numbers and letters 

 =COUNTA 

Median - Returns the middle value in the data 

 =MEDIAN 

 
Suggested Activity:  

Answer the following questions.  

1. Find the Sum of HP  
=SUM(D2:D13) (1680) 

2. What is the Average Level?   
=AVERAGE(C2:C13) (12.25) 

3. What is the Minimum Attack?   
 =MIN(F2:F13) (5) 
4. What is the Maximum Speed?  
 =MAX(J2:J13) (15) 
5. How many characters are there?  
 =COUNTA(A2:A13) (12) 
6. What is the Median Defense? 
 =MEDIAN(H2:H13) (8.5) 

Data Cleaning   [-minutes] 
Data cleaning involves preparing your data for analysis by ensuring it's in a usable format. This includes 

removing blank cells, eliminating duplicates, and standardizing formats.  

First, let’s check the spelling 

(I made the following spelling errors in the Data Cleaning tab) 

E7 (Sord should be Sword)  



   
 

 

E3 (Clawz should be Claws) 

L8 (Brake should be Break) 

L2 (Kross should be Cross) 

Click on Review → Spelling (In the Proofing Group) and fix the above errors. 

Second, remove the empty rows. There are 5 empty rows. Select the entire dataset, and add a filter to 

the first row (Home → Sort and Filter → Filter). Click the Select All checkbox to deselect all of them. 

Then select just Blanks, then OK. Select first row, then press CTRL+SHIFT+END to select all rows. Right-

click the selected rows and then click Delete Rows. Finally, on the Data tab, click Clear, then click Filter. 

Third, remove the duplicate rows. There are several duplicate rows (5 and 6), (9 and 10), (14 and 15). 

Select the entire dataset, then go to Data → Remove Duplicates. We can select columns that have 

duplicates. Let’s click Unselect All, then click on Character Name, then click OK. That removes three of 

the duplicates. Then remove the filter by clicking on Data → Sort and Filter → Filter. Unchecking a 

column means that it will not remove duplicates for that column. 

Last, let’s trim the whitespace. If you look in column L, there are two spaces between the words, when 

there should only be one.  

Select all the data using CTRL+SHIFT+END. 

On the Home tab, click Find & Select (in Editing tab), then Replace. 

In Find what, type 2 spaces. In Replace with, type 1 space. 

Click Find All, then click Replace All. 

Click the Close icon. 

Finally, our data has been cleaned! 

  

Suggested Activity: Create another if statement. See below 

Sort and Filter   [-minutes] 
Now that the data has been cleaned, we can move on to sorting and filtering. Click on the Sort 

and Filter tab.  

Let’s practice Filtering. How many characters have a Magic power of 6? 

How many characters have a Luck of 7?  

How many characters have 130 HP? 

How many characters are either Level 12 or 13? 

Show class how to sort Character Name by A to Z order. Then Z to A order. (Add a filter, then 

click on the filter arrow. Click Sort A to Z, then click Z to A.  



   
 

 

Practice a custom sort 

Advanced Functions   [-minutes] 
Here are some of the most common functions a Data Analyst might use 
IF - returns values based on a true or false condition 
=IF(logical_test, [value_if_true], [value_if_false]) 
The condition is referred to as logical_test, which can check things like: 

• If a number is greater than another number > 
• If a number is smaller than another number < 
• If a number or text is equal to something = 

 
IFS - returns values based on one or more true or false conditions 
=IFS(logical_test1, value_if_true1, [logical_test2, value_if_true2], [logical_test3; ...) 
 
COUNTIF - returns the count of cells in a range that meet a single condition 
=COUNTIF(range, criteria) 
=COUNTIF(Where do you want to look?, What do you want to look for?) 
 
SUMIF - calculates the sum of values in a range based on a true or false condition. 
=SUMIF(range, criteria, [sum_range]) 
 
The condition is referred to as criteria, which can check things like: 

• If a number is greater than another number > 
• If a number is smaller than another number < 
• If a number or text is equal to something = 

The [sum_range] is the range where the function calculates the sum. 
The [sum_range] is optional. If not specified, the function calculates the sum of the same range 
as the condition. 

Advanced Functions Practice [-minutes] 
If - If a character has a defense of 10 or higher, they can fight the boss. Add a new column named “Ready for 
the Boss Fight?” in Column M. 
=IF(H2>=10,"Yes","No") Use the AutoFill to automatically fill in the below cells.  
 
Ifs - If a character has a speed of 12 or higher, they are "Fast". If their speed is 8 to 11, they are "Normal". If 
their speed is less than or equal to 7, they are "Slow". Add a new column named “Speed Category” in 
Column N. 
 
=IFS(J2>=12,"Fast",J2>=8,"Normal",J2<=7,"Slow") 
 
CountIf – How many characters have HP over 140? 
=COUNTIF(D2:D13, ">140") The answer is 5 
 
How many characters have a magic or 9 or less? 
=COUNTIF(G2:G13, "<=8") The answer is 9 



   
 

 

 

VLOOKUP Function   [-minutes] 
VLOOKUP is a function in Excel that helps you find a piece of information based on another 

value in a table... VLOOKUP works by searching down the first column of a table to find a 

match. Once it locates that match, it retrieves data from the specified column of the same row. 

=VLOOKUP(lookup_value, table_array, col_index_num, [range_lookup]) 

Lookup_value: What you want to look up. 

Table_array: Where you want to look for it. Must be in the first column.  

Col_index_num: the column number in the range containing the value to return. The input is 

the number of the column, counted from the left: 

Range_lookup: return an Approximate or Exact match TRUE if numbers (1) or FALSE if text (0). 

 

*If someone asks about XLOOKUP, it is an improved version of VLOOKUP that works in any 

direction and returns exact matches by default, making it easier and more convenient to use 

than VLOOKUP. However, XLOOKUP is not available in Excel 2016 and Excel 2019. I am using 

VLOOKUP since it is compatible with any Excel version and students may not have the current 

Excel version.  

 

*HLOOKUP (Horizontal Lookup) in Excel is a built-in function that enables users to find data in 

tables horizontally. HLOOKUP is useful in scenarios where you need to retrieve information 

from a data set that is arranged in rows rather than columns. 

 

Pivot Table   [-minutes] 
A PivotTable is an interactive way to quickly summarize large amounts of data. 

 
In order to use a PivotTable, you must first turn format the data as a table 

On the Home tab, in the Tables group, click Format as Table.  

Select Light Gray, Table Style Medium 15. Select any cell in the table, then click Insert → 
PivotTable 

Move Character Name to Rows, Move Enemies to Values.  

Let’s insert a chart. Click anywhere in the PivotTable. Click Insert → Recommended Charts (In 
the Charts group) 

Insert a Slicer: PivotTable Analyze → Filter → Insert Slicer 



   
 

 

Finding More Help  [- minutes]  
 

• Demonstrate how to access the Excel help menu 

• Encourage use of online help 

• Share other resources (Northstar, LinkedIn Learning, GCFLearnFree, etc.) 

Project Outcome Survey [- minutes] 
 
• Explain ProjectOutcome.org’s initiative and its impact on public libraries as an incentive to 
complete the Survey - helps libraries understand and share the impact of programs and 
services. Surveys are anonymous.  
• Ask participants to complete the online Project Outcome Survey before ending or leaving the 
meeting by placing link in chat.  
• [Insert Link] 

*Resources Referenced 
 

• Insert resources referenced for your class, such as GCF Learn Free or LinkedIn Learning 
 


